using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$(.*):([^$]*)";
string input = @"$Label1: Text1
Text1 possibly continues
$Label2: Text2
$Label3: Text3
Text3 possibly continues";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}