# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[img\](https?:\/\/.*?\.(?:jpe?g|gif|png|bmp).*)\[\/img\]/<img src="$1" alt="" \/>/s;t' <<< "[img]https://somelink/2/3/pic.jpg?w=bla[/img]"