use strict;
my $str = '[img]https://somelink/2/3/pic.jpg?w=bla[/img]';
my $regex = qr~\[img\](https?://.*?\.(?:jpe?g|gif|png|bmp).*)\[/img\]~sp;
my $subst = '<img src="$1" alt="" />';
my $result = $str =~ s~$regex~$subst~r;
print "The result of the substitution is' $result\n";