re = /\[img\](https?:\/\/.*?\.(?:jpe?g|gif|png|bmp).*)\[\/img\]/
str = '[img]https://somelink/2/3/pic.jpg?w=bla[/img]'
subst = '<img src="$1" alt="" />'
result = str.sub(re, subst)
# Print the result of the substitution
puts result