#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)\[img\](https?://.*?\.(?:jpe?g|gif|png|bmp).*)\[/img\]"
Local $sString = "[img]https://somelink/2/3/pic.jpg?w=bla[/img]"
Local $sSubst = "<img src="$1" alt="" />"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)