$re = '~\[img\](https?://.*?\.(?:jpe?g|gif|png|bmp).*)\[/img\]~s';
$str = '[img]https://somelink/2/3/pic.jpg?w=bla[/img]';
$subst = "<img src=\"$1\" alt=\"\" />";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;