const regex = new RegExp('\\[img\\](https?://.*?\\.(?:jpe?g|gif|png|bmp).*)\\[/img\\]', 's')
const str = `[img]https://somelink/2/3/pic.jpg?w=bla[/img]`;
const subst = `<img src="$1" alt="" />`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);