#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?ms)\s*-\s*(\(\d{5}\))\s*-\s*(\w{3}\s\d{4}\w?-\d{3}-(?:[^.\s]|\b\s\b)+)\s*-\s*([^.]+\.txt)$"
Local $sString = "201308 - (82608) - MAC 2233-007-Methods of Calculus - Klingler, Lee.txt" & @CRLF & _
"201308 - (12345) - ABC 2233L-007-course Name 1 - last, first.txt" & @CRLF & _
"@ @ @ @ @ @ 123 abc - a-1 - b-2.txt" & @CRLF & _
"201308-(82609) -MAC 2233-007-Methods of Calculus - Klingler, Lee.txt" & @CRLF & _
"201308 - (12345)-ABC 2233L-007-course Name-last, first.txt" & @CRLF & _
"201308-(12345)-ABC 2233L-007-course Name-last, first.txt"
Local $sSubst = " - \1 - \2 - \3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)