using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*-\s*(\(\d{5}\))\s*-\s*(\w{3}\s\d{4}\w?-\d{3}-(?:[^.\s]|\b\s\b)+)\s*-\s*([^.]+\.txt)$";
string substitution = @" - \1 - \2 - \3";
string input = @"201308 - (82608) - MAC 2233-007-Methods of Calculus - Klingler, Lee.txt
201308 - (12345) - ABC 2233L-007-course Name 1 - last, first.txt
@ @ @ @ @ @ 123 abc - a-1 - b-2.txt
201308-(82609) -MAC 2233-007-Methods of Calculus - Klingler, Lee.txt
201308 - (12345)-ABC 2233L-007-course Name-last, first.txt
201308-(12345)-ABC 2233L-007-course Name-last, first.txt";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}