// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)\s*-\s*(\(\d{5}\))\s*-\s*(\w{3}\s\d{4}\w?-\d{3}-(?:[^.\s]|\b\s\b)+)\s*-\s*([^.]+\.txt)$").unwrap();
let string = "201308 - (82608) - MAC 2233-007-Methods of Calculus - Klingler, Lee.txt
201308 - (12345) - ABC 2233L-007-course Name 1 - last, first.txt
@ @ @ @ @ @ 123 abc - a-1 - b-2.txt
201308-(82609) -MAC 2233-007-Methods of Calculus - Klingler, Lee.txt
201308 - (12345)-ABC 2233L-007-course Name-last, first.txt
201308-(12345)-ABC 2233L-007-course Name-last, first.txt";
let substitution = " - \\1 - \\2 - \\3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}