import re
regex = re.compile(r"\s*-\s*(\(\d{5}\))\s*-\s*(\w{3}\s\d{4}\w?-\d{3}-(?:[^.\s]|\b\s\b)+)\s*-\s*([^.]+\.txt)$", flags=re.MULTILINE | re.DOTALL)
test_str = ("201308 - (82608) - MAC 2233-007-Methods of Calculus - Klingler, Lee.txt\n"
"201308 - (12345) - ABC 2233L-007-course Name 1 - last, first.txt\n"
"@ @ @ @ @ @ 123 abc - a-1 - b-2.txt\n"
"201308-(82609) -MAC 2233-007-Methods of Calculus - Klingler, Lee.txt\n"
"201308 - (12345)-ABC 2233L-007-course Name-last, first.txt\n"
"201308-(12345)-ABC 2233L-007-course Name-last, first.txt")
subst = " - \\1 - \\2 - \\3"
result = regex.sub(subst, test_str)
if result:
print(result)