import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*-\\s*(\\(\\d{5}\\))\\s*-\\s*(\\w{3}\\s\\d{4}\\w?-\\d{3}-(?:[^.\\s]|\\b\\s\\b)+)\\s*-\\s*([^.]+\\.txt)$";
final String string = "201308 - (82608) - MAC 2233-007-Methods of Calculus - Klingler, Lee.txt\n"
+ "201308 - (12345) - ABC 2233L-007-course Name 1 - last, first.txt\n"
+ "@ @ @ @ @ @ 123 abc - a-1 - b-2.txt\n"
+ "201308-(82609) -MAC 2233-007-Methods of Calculus - Klingler, Lee.txt\n"
+ "201308 - (12345)-ABC 2233L-007-course Name-last, first.txt\n"
+ "201308-(12345)-ABC 2233L-007-course Name-last, first.txt";
final String subst = " - \\1 - \\2 - \\3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}