#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^_-](?!.*(?:__|--|_-|-_))(?:.*[^_-])?$"
Local $sString = "abc" & @CRLF & _
"123" & @CRLF & _
"abc_123" & @CRLF & _
"123-blah_hello" & @CRLF & _
"_abc" & @CRLF & _
"-123" & @CRLF & _
"abc__123" & @CRLF & _
"def_-456" & @CRLF & _
"abc_" & @CRLF & _
"123-"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")