$re = '/^[^_-](?!.*(?:__|--|_-|-_))(?:.*[^_-])?$/m';
$str = 'abc
123
abc_123
123-blah_hello
_abc
-123
abc__123
def_-456
abc_
123-';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);