import re
regex = re.compile(r"^[^_-](?!.*(?:__|--|_-|-_))(?:.*[^_-])?$", flags=re.MULTILINE)
test_str = ("abc\n"
"123\n"
"abc_123\n"
"123-blah_hello\n"
"_abc\n"
"-123\n"
"abc__123\n"
"def_-456\n"
"abc_\n"
"123-")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")