import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(=>\\s*\"?)(\\d+)";
final String string = "$_ArrFinal = array(\"A\"=>4, \"B\" =>5, \"C\" => 6, \"D\" => 7, \"E\"=>7, \"F\" => \"8\",...)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}