re = /(=>\s*"?)(\d+)/
str = '$_ArrFinal = array("A"=>4, "B" =>5, "C" => 6, "D" => 7, "E"=>7, "F" => "8",...)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end