// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(=>\s*"?)(\d+)"#).unwrap();
let string = "$_ArrFinal = array(\"A\"=>4, \"B\" =>5, \"C\" => 6, \"D\" => 7, \"E\"=>7, \"F\" => \"8\",...)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}