const regex = new RegExp('(=>\\s*"?)(\\d+)', 'g')
const str = `\$_ArrFinal = array("A"=>4, "B" =>5, "C" => 6, "D" => 7, "E"=>7, "F" => "8",...)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}