# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?!.*admin)(.*?)\\/?$/\/\1\//gm;t' <<< "index
index/
admin
admin/
somehting
something/
something/foo/bar/
something/foo/baz
admin/edit.html
administration/index.html
user887/admin/index.shtml
"