import Foundation
let pattern = #"^(?!.*admin)(.*?)\/?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
index
index/
admin
admin/
somehting
something/
something/foo/bar/
something/foo/baz
admin/edit.html
administration/index.html
user887/admin/index.shtml
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"/\1/"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)