#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?!.*admin)(.*?)\/?$"
Local $sString = "index" & @CRLF & _
"index/" & @CRLF & _
"admin" & @CRLF & _
"admin/" & @CRLF & _
"somehting" & @CRLF & _
"something/" & @CRLF & _
"something/foo/bar/" & @CRLF & _
"something/foo/baz" & @CRLF & _
"admin/edit.html" & @CRLF & _
"administration/index.html" & @CRLF & _
"user887/admin/index.shtml" & @CRLF & _
""
Local $sSubst = "/\1/"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)