use strict;
my $str = 'index
index/
admin
admin/
somehting
something/
something/foo/bar/
something/foo/baz
admin/edit.html
administration/index.html
user887/admin/index.shtml
';
my $regex = qr/^(?!.*admin)(.*?)\/?$/mp;
my $subst = '/\\1/';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";