$re = '/^(?!.*admin)(.*?)\/?$/m';
$str = 'index
index/
admin
admin/
somehting
something/
something/foo/bar/
something/foo/baz
admin/edit.html
administration/index.html
user887/admin/index.shtml
';
$subst = "/\1/";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;