using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*admin)(.*?)\/?$";
string substitution = @"/\1/";
string input = @"index
index/
admin
admin/
somehting
something/
something/foo/bar/
something/foo/baz
admin/edit.html
administration/index.html
user887/admin/index.shtml
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}