#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[\r\n]+"
Local $sString = "car" & @CRLF & _
"" & @CRLF & _
"house" & @CRLF & _
"home" & @CRLF & _
"computer" & @CRLF & _
"go" & @CRLF & _
"" & @CRLF & _
"went"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)