import Foundation
let pattern = #"[\r\n]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
car
house
home
computer
go
went
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)