$re = '/[\r\n]+/';
$str = 'car
house
home
computer
go
went';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;