# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^((?:[^,]+,\s+){9})[^,]+/$1x/;t' <<< "value1, value2, value3, value4, value5, value6, value7, value8, value9, value10"