package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^((?:[^,]+,\s+){9})[^,]+`)
var str = []byte(`value1, value2, value3, value4, value5, value6, value7, value8, value9, value10`)
var substitution = []byte("$1x")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}