// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^((?:[^,]+,\s+){9})[^,]+").unwrap();
let string = "value1, value2, value3, value4, value5, value6, value7, value8, value9, value10";
let substitution = "$1x";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}