import re
regex = re.compile(r"^((?:[^,]+,\s+){9})[^,]+")
test_str = "value1, value2, value3, value4, value5, value6, value7, value8, value9, value10"
subst = "$1x"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)