#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^(?:[^,]+,\s+){9}\K[^,]+"
Local $sString = "value1, value2, value3, value4, value5, value6, value7, value8, value9, value10"
Local $sSubst = "x"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)