import Foundation
let pattern = #"^(?:[^,]+,\s+){9}\K[^,]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"value1, value2, value3, value4, value5, value6, value7, value8, value9, value10"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"x"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}