using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[^,]+,\s+){9}\K[^,]+";
string substitution = @"x";
string input = @"value1, value2, value3, value4, value5, value6, value7, value8, value9, value10";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}