re = /^(?:[^,]+,\s+){9}\K[^,]+/
str = 'value1, value2, value3, value4, value5, value6, value7, value8, value9, value10'
subst = 'x'
result = str.sub(re, subst)
# Print the result of the substitution
puts result