$re = '/^(?:[^,]+,\s+){9}\K[^,]+/';
$str = 'value1, value2, value3, value4, value5, value6, value7, value8, value9, value10';
$subst = "x";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;