using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?(DEFINE)
(?<number> (?>-? (?= [1-9]|0(?!\d) ) \d+ (\.\d+)? ([eE] [+-]? \d+)?) )
(?<boolean> (?> true | false | null ))
(?<unquoted> (?> ([^""\\]* | \\ [""\\bfnrt\/] | \\ u [0-9a-f]{4} )* ))
(?<string> (?>"" (?&unquoted) "" ))
(?<array> (?> \[ (?: (?&json) (?: , (?&json) )* )? \s* \] ))
(?<pair> (?> \s* (?&string) \s* : (?&json) ))
(?<object> (?>\{ (?: (?&pair) (?: , (?&pair) )* )? \s* \} ))
(?<json> (?>\s* (?: (?&number) | (?&boolean) | (?&string) | (?&array) | (?&object) ) \s* ))
)
(?<="") # Lookbehind for quote before parent key string
(?&unquoted) # parent key string
(?= # Lookahead for object properties including unique property marker
""\s*:\s*{\s*
(?: (?&pair) (?: , (?&pair) )* )? # any number of property key value pairs, optional.
(?:(?:\s* , )?\s* ""type""\s*:\s*""title"") # unique property marker, optionally perfixed with comma.
(?: \s*, (?&pair) )* # any number of property key value pairs, optional.
\s*}
)";
string input = @" ..
""id"": ""Xkt@"",
""name"": ""My Email"",
""type"": ""email""
},
""Item of Equipment"": {
""id"": ""title"",
""title"": {},
""name"": ""Item of Equipment"",
""type"": ""title""
},
""My Date"": {
""id"": ""nYcK"",
""name"": ""My Date"",
""type"": ""date"",
..
""Item of Equipment"": {
""type"": ""title"",
""id"": ""title"",
""title"": {},
""name"": ""Item of Equipment""
},";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}