import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(DEFINE)\n"
+ " (?<number> (?>-? (?= [1-9]|0(?!\\d) ) \\d+ (\\.\\d+)? ([eE] [+-]? \\d+)?) )\n"
+ " (?<boolean> (?> true | false | null ))\n"
+ " (?<unquoted> (?> ([^\"\\\\]* | \\\\ [\"\\\\bfnrt\\/] | \\\\ u [0-9a-f]{4} )* ))\n"
+ " (?<string> (?>\" (?&unquoted) \" ))\n"
+ " (?<array> (?> \\[ (?: (?&json) (?: , (?&json) )* )? \\s* \\] ))\n"
+ " (?<pair> (?> \\s* (?&string) \\s* : (?&json) ))\n"
+ " (?<object> (?>\\{ (?: (?&pair) (?: , (?&pair) )* )? \\s* \\} ))\n"
+ " (?<json> (?>\\s* (?: (?&number) | (?&boolean) | (?&string) | (?&array) | (?&object) ) \\s* ))\n"
+ " )\n"
+ "(?<=\") # Lookbehind for quote before parent key string\n"
+ "(?&unquoted) # parent key string \n"
+ "(?= # Lookahead for object properties including unique property marker\n"
+ "\"\\s*:\\s*\\{\\s*\n"
+ "(?: (?&pair) (?: , (?&pair) )* )? # any number of property key value pairs, optional.\n"
+ "(?:(?:\\s* , )?\\s* \"type\"\\s*:\\s*\"title\") # unique property marker, optionally perfixed with comma.\n"
+ "(?: \\s*, (?&pair) )* # any number of property key value pairs, optional.\n"
+ "\\s*\\}\n"
+ ")";
final String string = " ..\n"
+ " \"id\": \"Xkt@\",\n"
+ " \"name\": \"My Email\",\n"
+ " \"type\": \"email\"\n"
+ " },\n"
+ " \"Item of Equipment\": {\n"
+ " \"id\": \"title\",\n"
+ " \"title\": {},\n"
+ " \"name\": \"Item of Equipment\",\n"
+ " \"type\": \"title\"\n"
+ " },\n"
+ " \"My Date\": {\n"
+ " \"id\": \"nYcK\",\n"
+ " \"name\": \"My Date\",\n"
+ " \"type\": \"date\",\n"
+ " ..\n\n\n"
+ "\"Item of Equipment\": {\n"
+ " \"type\": \"title\",\n"
+ " \"id\": \"title\",\n"
+ " \"title\": {},\n"
+ " \"name\": \"Item of Equipment\"\n"
+ " \n"
+ " },";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}