import re
regex = re.compile(r"""
(?(DEFINE)
(?<number> (?>-? (?= [1-9]|0(?!\d) ) \d+ (\.\d+)? ([eE] [+-]? \d+)?) )
(?<boolean> (?> true | false | null ))
(?<unquoted> (?> ([^"\\]* | \\ ["\\bfnrt\/] | \\ u [0-9a-f]{4} )* ))
(?<string> (?>" (?&unquoted) " ))
(?<array> (?> \[ (?: (?&json) (?: , (?&json) )* )? \s* \] ))
(?<pair> (?> \s* (?&string) \s* : (?&json) ))
(?<object> (?>\{ (?: (?&pair) (?: , (?&pair) )* )? \s* \} ))
(?<json> (?>\s* (?: (?&number) | (?&boolean) | (?&string) | (?&array) | (?&object) ) \s* ))
)
(?<=") # Lookbehind for quote before parent key string
(?&unquoted) # parent key string
(?= # Lookahead for object properties including unique property marker
"\s*:\s*{\s*
(?: (?&pair) (?: , (?&pair) )* )? # any number of property key value pairs, optional.
(?:(?:\s* , )?\s* "type"\s*:\s*"title") # unique property marker, optionally perfixed with comma.
(?: \s*, (?&pair) )* # any number of property key value pairs, optional.
\s*}
)
""", flags=re.VERBOSE)
test_str = (" ..\n"
" \"id\": \"Xkt@\",\n"
" \"name\": \"My Email\",\n"
" \"type\": \"email\"\n"
" },\n"
" \"Item of Equipment\": {\n"
" \"id\": \"title\",\n"
" \"title\": {},\n"
" \"name\": \"Item of Equipment\",\n"
" \"type\": \"title\"\n"
" },\n"
" \"My Date\": {\n"
" \"id\": \"nYcK\",\n"
" \"name\": \"My Date\",\n"
" \"type\": \"date\",\n"
" ..\n\n\n"
"\"Item of Equipment\": {\n"
" \"type\": \"title\",\n"
" \"id\": \"title\",\n"
" \"title\": {},\n"
" \"name\": \"Item of Equipment\"\n"
" \n"
" },")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")