use strict;
my $str = ' ..
"id": "Xkt@",
"name": "My Email",
"type": "email"
},
"Item of Equipment": {
"id": "title",
"title": {},
"name": "Item of Equipment",
"type": "title"
},
"My Date": {
"id": "nYcK",
"name": "My Date",
"type": "date",
..
"Item of Equipment": {
"type": "title",
"id": "title",
"title": {},
"name": "Item of Equipment"
},';
my $regex = qr/(?(DEFINE)
(?<number> (?>-? (?= [1-9]|0(?!\d) ) \d+ (\.\d+)? ([eE] [+-]? \d+)?) )
(?<boolean> (?> true | false | null ))
(?<unquoted> (?> ([^"\\]* | \\ ["\\bfnrt\/] | \\ u [0-9a-f]{4} )* ))
(?<string> (?>" (?&unquoted) " ))
(?<array> (?> \[ (?: (?&json) (?: , (?&json) )* )? \s* \] ))
(?<pair> (?> \s* (?&string) \s* : (?&json) ))
(?<object> (?>\{ (?: (?&pair) (?: , (?&pair) )* )? \s* \} ))
(?<json> (?>\s* (?: (?&number) | (?&boolean) | (?&string) | (?&array) | (?&object) ) \s* ))
)
(?<=") # Lookbehind for quote before parent key string
(?&unquoted) # parent key string
(?= # Lookahead for object properties including unique property marker
"\s*:\s*{\s*
(?: (?&pair) (?: , (?&pair) )* )? # any number of property key value pairs, optional.
(?:(?:\s* , )?\s* "type"\s*:\s*"title") # unique property marker, optionally perfixed with comma.
(?: \s*, (?&pair) )* # any number of property key value pairs, optional.
\s*}
)/xp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}