// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?x)(?(DEFINE)
(?<number> (?>-? (?= [1-9]|0(?!\d) ) \d+ (\.\d+)? ([eE] [+-]? \d+)?) )
(?<boolean> (?> true | false | null ))
(?<unquoted> (?> ([^"\\]* | \\ ["\\bfnrt\/] | \\ u [0-9a-f]{4} )* ))
(?<string> (?>" (?&unquoted) " ))
(?<array> (?> \[ (?: (?&json) (?: , (?&json) )* )? \s* \] ))
(?<pair> (?> \s* (?&string) \s* : (?&json) ))
(?<object> (?>\{ (?: (?&pair) (?: , (?&pair) )* )? \s* \} ))
(?<json> (?>\s* (?: (?&number) | (?&boolean) | (?&string) | (?&array) | (?&object) ) \s* ))
)
(?<=") # Lookbehind for quote before parent key string
(?&unquoted) # parent key string
(?= # Lookahead for object properties including unique property marker
"\s*:\s*{\s*
(?: (?&pair) (?: , (?&pair) )* )? # any number of property key value pairs, optional.
(?:(?:\s* , )?\s* "type"\s*:\s*"title") # unique property marker, optionally perfixed with comma.
(?: \s*, (?&pair) )* # any number of property key value pairs, optional.
\s*}
)"#).unwrap();
let string = " ..
\"id\": \"Xkt@\",
\"name\": \"My Email\",
\"type\": \"email\"
},
\"Item of Equipment\": {
\"id\": \"title\",
\"title\": {},
\"name\": \"Item of Equipment\",
\"type\": \"title\"
},
\"My Date\": {
\"id\": \"nYcK\",
\"name\": \"My Date\",
\"type\": \"date\",
..
\"Item of Equipment\": {
\"type\": \"title\",
\"id\": \"title\",
\"title\": {},
\"name\": \"Item of Equipment\"
},";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}