const regex = /(?(DEFINE)
(?<number> (?>-? (?= [1-9]|0(?!\d) ) \d+ (\.\d+)? ([eE] [+-]? \d+)?) )
(?<boolean> (?> true | false | null ))
(?<unquoted> (?> ([^"\\]* | \\ ["\\bfnrt\/] | \\ u [0-9a-f]{4} )* ))
(?<string> (?>" (?&unquoted) " ))
(?<array> (?> \[ (?: (?&json) (?: , (?&json) )* )? \s* \] ))
(?<pair> (?> \s* (?&string) \s* : (?&json) ))
(?<object> (?>\{ (?: (?&pair) (?: , (?&pair) )* )? \s* \} ))
(?<json> (?>\s* (?: (?&number) | (?&boolean) | (?&string) | (?&array) | (?&object) ) \s* ))
)
(?<=") # Lookbehind for quote before parent key string
(?&unquoted) # parent key string
(?= # Lookahead for object properties including unique property marker
"\s*:\s*{\s*
(?: (?&pair) (?: , (?&pair) )* )? # any number of property key value pairs, optional.
(?:(?:\s* , )?\s* "type"\s*:\s*"title") # unique property marker, optionally perfixed with comma.
(?: \s*, (?&pair) )* # any number of property key value pairs, optional.
\s*}
)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?(DEFINE)
(?<number> (?>-? (?= [1-9]|0(?!\\d) ) \\d+ (\\.\\d+)? ([eE] [+-]? \\d+)?) )
(?<boolean> (?> true | false | null ))
(?<unquoted> (?> ([^"\\\\]* | \\\\ ["\\\\bfnrt\\\/] | \\\\ u [0-9a-f]{4} )* ))
(?<string> (?>" (?&unquoted) " ))
(?<array> (?> \\[ (?: (?&json) (?: , (?&json) )* )? \\s* \\] ))
(?<pair> (?> \\s* (?&string) \\s* : (?&json) ))
(?<object> (?>\\{ (?: (?&pair) (?: , (?&pair) )* )? \\s* \\} ))
(?<json> (?>\\s* (?: (?&number) | (?&boolean) | (?&string) | (?&array) | (?&object) ) \\s* ))
)
(?<=") # Lookbehind for quote before parent key string
(?&unquoted) # parent key string
(?= # Lookahead for object properties including unique property marker
"\\s*:\\s*{\\s*
(?: (?&pair) (?: , (?&pair) )* )? # any number of property key value pairs, optional.
(?:(?:\\s* , )?\\s* "type"\\s*:\\s*"title") # unique property marker, optionally perfixed with comma.
(?: \\s*, (?&pair) )* # any number of property key value pairs, optional.
\\s*}
)', 'g')
const str = ` ..
"id": "Xkt@",
"name": "My Email",
"type": "email"
},
"Item of Equipment": {
"id": "title",
"title": {},
"name": "Item of Equipment",
"type": "title"
},
"My Date": {
"id": "nYcK",
"name": "My Date",
"type": "date",
..
"Item of Equipment": {
"type": "title",
"id": "title",
"title": {},
"name": "Item of Equipment"
},`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}