using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*(</p>)).*|\s+</p>";
string substitution = @"";
string input = @"<div>blah</div>
<p class=""mb-40px""></g></svg> </a>
</li>
</ul>
</div>
</p>
<p class=""mb-40px"">Foarte frumos lucru
</p>
<p class=""mb-40px"">I love cars</p>
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}