const regex = new RegExp('^(?!.*(</p>)).*|\\s+</p>', 'gm')
const str = `<div>blah</div>
<p class="mb-40px"></g></svg> </a>
</li>
</ul>
</div>
</p>
<p class="mb-40px">Foarte frumos lucru
</p>
<p class="mb-40px">I love cars</p>
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);