import re
regex = re.compile(r"^(?!.*(</p>)).*|\s+</p>", flags=re.MULTILINE)
test_str = ("<div>blah</div>\n"
"<p class=\"mb-40px\"></g></svg> </a>\n"
" </li>\n"
" \n"
" </ul>\n\n"
" </div>\n"
" </p>\n\n"
" <p class=\"mb-40px\">Foarte frumos lucru\n"
" </p>\n"
"<p class=\"mb-40px\">I love cars</p>\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)