import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*(</p>)).*|\\s+</p>";
final String string = "<div>blah</div>\n"
+ "<p class=\"mb-40px\"></g></svg> </a>\n"
+ " </li>\n"
+ " \n"
+ " </ul>\n\n"
+ " </div>\n"
+ " </p>\n\n"
+ " <p class=\"mb-40px\">Foarte frumos lucru\n"
+ " </p>\n"
+ "<p class=\"mb-40px\">I love cars</p>\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}