$re = '~^(?!.*(</p>)).*|\s+</p>~m';
$str = '<div>blah</div>
<p class="mb-40px"></g></svg> </a>
</li>
</ul>
</div>
</p>
<p class="mb-40px">Foarte frumos lucru
</p>
<p class="mb-40px">I love cars</p>
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;