#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\b(?<!\S)(?:(Lord|Lady|Ser)\s+)?(Agatha|John)?(?:\s*(?<=\b)(Cain))?(?<=\S)\b"
Local $sString = "Lord John Cain asked..." & @CRLF & _
"Ser John has..." & @CRLF & _
"Lady Agatha and Lord John are..." & @CRLF & _
"Lady Agatha Cain was..." & @CRLF & _
"Inside the castle, Lord Cain was speaking with Lady Cain." & @CRLF & _
"John was eating..." & @CRLF & _
"He looked at them. Cain was walking..." & @CRLF & _
"Cain is..." & @CRLF & _
"Outside the castle, in a small courtyard, a page was leading Ser" & @CRLF & _
"John and his horse into the stables." & @CRLF & _
"Yes, my lord... My Lord Tom, that is..." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")