import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?<!\\S)(?:(Lord|Lady|Ser)\\s+)?(Agatha|John)?(?:\\s*(?<=\\b)(Cain))?(?<=\\S)\\b";
final String string = "Lord John Cain asked...\n"
+ "Ser John has...\n"
+ "Lady Agatha and Lord John are...\n"
+ "Lady Agatha Cain was...\n"
+ "Inside the castle, Lord Cain was speaking with Lady Cain.\n"
+ "John was eating...\n"
+ "He looked at them. Cain was walking...\n"
+ "Cain is...\n"
+ "Outside the castle, in a small courtyard, a page was leading Ser\n"
+ "John and his horse into the stables.\n"
+ "Yes, my lord... My Lord Tom, that is...\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}